Back to overview
Degraded
Services Unavailable
Nov 18 at 01:04pm UTC
Affected services
fast-file.com
API Endpoint
Resolved
Nov 18 at 05:54pm UTC
Cloudflare has resolved the issue, and we are now monitoring our systems on our end.
Affected services
Created
Nov 18 at 01:04pm UTC
Connectivity is recovering, we'll keep this open until we see traffic at previous levels. See https://www.cloudflarestatus.com/incidents/8gmgl950y3h7 for details on the Cloudflare outage itself.
Affected services