Backend and File Storage System Upgrades
Resolved
Nov 19 at 12:23am UTC
The scheduled maintenance has been successfully completed, and all systems are now fully operational.
Affected services
Created
Nov 18 at 11:00pm UTC
We will be conducting scheduled maintenance to implement important upgrades to our backend infrastructure and file storage system. These improvements are part of our ongoing efforts to increase performance, enhance stability, and ensure a more reliable file-sharing experience for all users.
During the maintenance window, certain features may be temporarily unavailable. This may include slower response times, intermittent access issues, or short service interruptions affecting file uploads, downloads, and overall platform access.
Our team will work diligently to complete the upgrades as efficiently as possible and minimize the impact on your workflow.
If you encounter any unexpected issues after the maintenance, please don’t hesitate to contact our support team.
Affected services