Upstream Server Failure
Resolved
May 12, 2026 at 7:21pm UTC
The issue was caused by a failing upstream server within the upload infrastructure. The affected server has been removed from the load balancer rotation, and upload services have recovered successfully. Users should now be able to upload files without errors.
Affected services
Updated
May 12, 2026 at 4:22pm UTC
Our team has identified the affected upstream server and continues to work on mitigation measures. Users may still experience intermittent issues when uploading files. We are monitoring the situation closely and working to fully restore stable service as quickly as possible.
Affected services
Created
May 12, 2026 at 3:38pm UTC
We are aware of an issue affecting file uploads due to an upstream server failure. Some users may encounter errors or failed uploads while using the service. We are actively working to resolve the problem as quickly as possible and will provide updates once more information is available.
Affected services